print from documenttoolkit sl5?

Jun 8, 2012 at 11:12 AM

We're trying to print from the xps viewer (sl5, documenttoolkit 2.5.2) but it doesn't work. It prints only empty pages or just lines and boxes but no texts.

We switched from sl4, it was too slow because of the big amout of data.

Is there a way to print correctly in sl5 with the xps viewer? Can i print in bitmap only mode?

Thanks

imre

 

 

Coordinator
Jun 8, 2012 at 2:03 PM

Hi imre,

Could you send a copy of this document to kozw [at] firstfloorsoftware.com, so I can take a look?

- Koen

Jun 8, 2012 at 2:33 PM
Edited Jun 8, 2012 at 3:21 PM

Actually, i can't print out properly even the test document from your demo application.

In the meantime we've tried it on an other computer with another printer. On that computer the printing was ok but it was very slow and sent about 100MB/page.

I assume it printed it in bitmap mode. Is it possible that when i print to a post script printer then it is fast but doesn't print correctly (vector mode), and on a "non post script" printer it sends it as bitmap?

Have you tried to print from the demo application to a post script printer? (if not you can try it by download and install pdfforge from pdfforge.org. It's a post script pdf printer)

thanks

imre

p.s: i sent you one of our document.

Coordinator
Jun 11, 2012 at 10:15 AM

Received the document, will look into it. Support for postscript printers has been tested.

- Koen

Jun 11, 2012 at 3:43 PM

Thanks!

Jun 25, 2012 at 12:20 PM

Hi Koen,

Just to add that I'm currently having the same problem.  I've got a network printer set up with postscript support, and if I send a sample postscript file to it directly using Ghostscript it prints correctly.  However printing from SL5/doc toolkit, whilst the correct number of pages appear, they only contain garbled characters.

Cheers,

Phil

 

Coordinator
Jun 26, 2012 at 11:01 AM

There's an issue in Document Toolkit with PostScript printers. A PostScript printer requests the pages to print faster than document toolkit can generate, and there is no easy way to fix this. The problem is related to the event based print model of Silverlight's PrinterDocument and Document Toolkit's async loading behavior of pages.

This looks like an issue that cannot be resolved without some major architectural changes. The only workaround for now is to use bitmap printing, which is far from ideal.

- Koen

Dec 20, 2012 at 11:30 AM

Do you know if in the next release this problem will be solved? 

As an alternative, how can I print in bitmap mode?

 

- Grifo

Coordinator
Dec 20, 2012 at 1:26 PM

A beta release of DocumentToolkit with support for bitmap printing is available for download at http://firstfloorsoftware.com/downloads/DocumentToolkit/beta/DocumentToolkit.2.5.4.0.zip

Set the DocumentPrinter.ForceBitmap to true for bitmap printing. This release also includes support for printing directly to the default printer (DocumentPrinter.UseDefaultPrinter), but when bitmap printing, UseDefaultPrinter is ignored (Silverlight API limitation).

- Koen

Dec 20, 2012 at 2:58 PM
Edited Dec 20, 2012 at 3:33 PM

Thanks!